$re = '/^(?!0{2,})\d+(?:\.\d+)?$/m';
$str = '0.1
11.04
0129
The numbers that should not be allowed are
.9
0009999.33
0007';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);