using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!0{2,})\d+(?:\.\d+)?$";
string input = @"0.1
11.04
0129
The numbers that should not be allowed are
.9
0009999.33
0007";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}