re = /^(?!0{2,})\d+(?:\.\d+)?$/m
str = '0.1
11.04
0129
The numbers that should not be allowed are
.9
0009999.33
0007'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end