package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<textarea[\s\S]+?<\/textarea>)`)
var str = `<p>
<textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">
<p>5051950</p>
</textarea>
</p>
<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">
a é í <abc>
</textarea></p>
<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5"></textarea></p>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}