use strict;
my $str = '<p>
<textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">
<p>5051950</p>
</textarea>
</p>
<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">
a é í <abc>
</textarea></p>
<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5"></textarea></p>
';
my $regex = qr/(<textarea[\s\S]+?<\/textarea>)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}