import re
regex = re.compile(r"(<textarea[\s\S]+?<\/textarea>)")
test_str = ("<p>\n"
" <textarea class=\"ckeditor-basic\" cols=\"100\" name=\"textAreaName\" required=\"required\" rows=\"5\">\n"
" <p>5051950</p>\n"
" </textarea>\n"
"</p>\n\n"
"<p><textarea class=\"ckeditor-basic\" cols=\"100\" name=\"textAreaName\" required=\"required\" rows=\"5\">\n\n"
"a é í <abc>\n\n"
"</textarea></p>\n\n"
"<p><textarea class=\"ckeditor-basic\" cols=\"100\" name=\"textAreaName\" required=\"required\" rows=\"5\"></textarea></p>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")