using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:(?:(\d+)d\s*)?(\d+)h\s*)?(\d+)m\s*)?(\d+)s$";
string substitution = @"$1 days $2 hours $3 minutes $4 days";
string input = @"1d 2h 3m 4s
1h 2m 3s
1m 2s
1s
1d2h3m4s
1h2m3s
1m2s
1s";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}