import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:(?:(\\d+)d\\s*)?(\\d+)h\\s*)?(\\d+)m\\s*)?(\\d+)s$";
final String string = "1d 2h 3m 4s\n"
+ "1h 2m 3s\n"
+ "1m 2s\n"
+ "1s\n"
+ "1d2h3m4s\n"
+ "1h2m3s\n"
+ "1m2s\n"
+ "1s";
final String subst = "$1 days $2 hours $3 minutes $4 days";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}