#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "sandwich((?:(?!forbidden).)*?)(ham|turkey)(.*?)(?!\2)(ham|turkey)"
Local $sString = "reuben sandwich with ham and turkey ham sandwich with cheese" & @CRLF & _
"reuben sandwich with turkey and ham ham sandwich with cheese" & @CRLF & _
"" & @CRLF & _
"reuben sandwich with ham and ham ham sandwich with cheese" & @CRLF & _
"reuben sandwich with forbidden ham and turkey ham sandwich with cheese" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")