import Foundation
let pattern = #"sandwich((?:(?!forbidden).)*?)(ham|turkey)(.*?)(?!\2)(ham|turkey)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
reuben sandwich with ham and turkey ham sandwich with cheese
reuben sandwich with turkey and ham ham sandwich with cheese
reuben sandwich with ham and ham ham sandwich with cheese
reuben sandwich with forbidden ham and turkey ham sandwich with cheese
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)