re = /sandwich((?:(?!forbidden).)*?)(ham|turkey)(.*?)(?!\2)(ham|turkey)/
str = 'reuben sandwich with ham and turkey ham sandwich with cheese
reuben sandwich with turkey and ham ham sandwich with cheese
reuben sandwich with ham and ham ham sandwich with cheese
reuben sandwich with forbidden ham and turkey ham sandwich with cheese
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end