import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "sandwich((?:(?!forbidden).)*?)(ham|turkey)(.*?)(?!\\2)(ham|turkey)";
final String string = "reuben sandwich with ham and turkey ham sandwich with cheese\n"
+ "reuben sandwich with turkey and ham ham sandwich with cheese\n\n"
+ "reuben sandwich with ham and ham ham sandwich with cheese\n"
+ "reuben sandwich with forbidden ham and turkey ham sandwich with cheese\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}