package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<datum>\d+\.\d+\.\d+)\s(?<uhrzeit>\d+\:\d+\:\d+)\,\s(?<einsatznr>\d+)\s(?<stichwort>.+?-.+?),(?<adresse>.+?),(?<text>.*)$`)
var str = `11.11.1111 22:22:22, 12345 Container - B1 mSoSi, Straße NRx Ort Gemeinde, Textmeldung
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}