$re = '/^(?<datum>\d+\.\d+\.\d+)\s(?<uhrzeit>\d+\:\d+\:\d+)\,\s(?<einsatznr>\d+)\s(?<stichwort>.+?-.+?),(?<adresse>.+?),(?<text>.*)$/m';
$str = '11.11.1111 22:22:22, 12345 Container - B1 mSoSi, Straße NRx Ort Gemeinde, Textmeldung
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);