import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<datum>\\d+\\.\\d+\\.\\d+)\\s(?<uhrzeit>\\d+\\:\\d+\\:\\d+)\\,\\s(?<einsatznr>\\d+)\\s(?<stichwort>.+?-.+?),(?<adresse>.+?),(?<text>.*)$";
final String string = "11.11.1111 22:22:22, 12345 Container - B1 mSoSi, Straße NRx Ort Gemeinde, Textmeldung\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}