import re
regex = re.compile(r"^(?<datum>\d+\.\d+\.\d+)\s(?<uhrzeit>\d+\:\d+\:\d+)\,\s(?<einsatznr>\d+)\s(?<stichwort>.+?-.+?),(?<adresse>.+?),(?<text>.*)$", flags=re.MULTILINE)
test_str = ("11.11.1111 22:22:22, 12345 Container - B1 mSoSi, Straße NRx Ort Gemeinde, Textmeldung\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")