using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'(\\'|[^']*?)'|""(\\""|[^""]*?)""|[^\s]+";
string input = @"sdasd ""asd'd'weqwe"" 'ddd' ggdf-c ""asda asdasd "" dfkkf 'da asd s' ""da asd sd""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}