$re = '/\'(\\\\\'|[^\']*?)\'|"(\\\\"|[^"]*?)"|[^\s]+/';
$str = 'sdasd "asd\'d\'weqwe" \'ddd\' ggdf-c "asda asdasd " dfkkf \'da asd s\' "da asd sd"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);