package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`'(\\'|[^']*?)'|"(\\"|[^"]*?)"|[^\s]+`)
var str = `sdasd "asd'd'weqwe" 'ddd' ggdf-c "asda asdasd " dfkkf 'da asd s' "da asd sd"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}