re = /'(\\'|[^']*?)'|"(\\"|[^"]*?)"|[^\s]+/
str = 'sdasd "asd\'d\'weqwe" \'ddd\' ggdf-c "asda asdasd " dfkkf \'da asd s\' "da asd sd"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end