#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)<meta[^>]*"(http[^"]+)"[^>]*>.*?(\1)"
Local $sString = "<meta property="og:url" content="https://mywebsite.com/en/truth.html"/>" & @CRLF & _
"" & @CRLF & _
"text text" & @CRLF & _
" " & @CRLF & _
"text" & @CRLF & _
"" & @CRLF & _
"<img src="index_files/flag_lang_de.jpg" width="28" height="19" title="de" alt="de" /></a> <a href="https://mywebsite.com/en/truth.html"><img src="index_files/flag_lang_ru.jpg" width="28" height="19" title="ru" alt="ru" /></a>" & @CRLF & _
"https://mywebsite.com/en/truth.html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")