using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<meta[^>]*""(http[^""]+)""[^>]*>.*?(\1)";
string input = @"<meta property=""og:url"" content=""https://mywebsite.com/en/truth.html""/>
text text
text
<img src=""index_files/flag_lang_de.jpg"" width=""28"" height=""19"" title=""de"" alt=""de"" /></a> <a href=""https://mywebsite.com/en/truth.html""><img src=""index_files/flag_lang_ru.jpg"" width=""28"" height=""19"" title=""ru"" alt=""ru"" /></a>
https://mywebsite.com/en/truth.html";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}