$re = '/<meta[^>]*"(http[^"]+)"[^>]*>.*?(\1)/ms';
$str = '<meta property="og:url" content="https://mywebsite.com/en/truth.html"/>
text text
text
<img src="index_files/flag_lang_de.jpg" width="28" height="19" title="de" alt="de" /></a> <a href="https://mywebsite.com/en/truth.html"><img src="index_files/flag_lang_ru.jpg" width="28" height="19" title="ru" alt="ru" /></a>
https://mywebsite.com/en/truth.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);