re = /<meta[^>]*"(http[^"]+)"[^>]*>.*?(\1)/m
str = '<meta property="og:url" content="https://mywebsite.com/en/truth.html"/>
text text
text
<img src="index_files/flag_lang_de.jpg" width="28" height="19" title="de" alt="de" /></a> <a href="https://mywebsite.com/en/truth.html"><img src="index_files/flag_lang_ru.jpg" width="28" height="19" title="ru" alt="ru" /></a>
https://mywebsite.com/en/truth.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end