#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\d.]+(?:.|[\r\n])*?(?=[.\x20\t]+\d{2,3}$)"
Local $sString = "5.2 Initializing the I/O Base Registers ................................. 51" & @CRLF & _
"5.3 Hiding and Function Disable troller Hub (PCH) Internal Devices 52" & @CRLF & _
"5.3.1 Fuse Disabled, Static Disabled, Non-Static Function Disable Device" & @CRLF & _
"Handling ................................................................. 53" & @CRLF & _
"8.4 SERR# Generation .................................................. 102" & @CRLF & _
"8.5 PCI Firmware Spec 3.0 Support ..................................... 103" & @CRLF & _
"8.6 ACPI Table and Methods for PCI Express* Support ................... 103" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")