using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\d.]+(?:.|[\r\n])*?(?=[.\x20\t]+\d{2,3}$)";
string input = @"5.2 Initializing the I/O Base Registers ................................. 51
5.3 Hiding and Function Disable troller Hub (PCH) Internal Devices 52
5.3.1 Fuse Disabled, Static Disabled, Non-Static Function Disable Device
Handling ................................................................. 53
8.4 SERR# Generation .................................................. 102
8.5 PCI Firmware Spec 3.0 Support ..................................... 103
8.6 ACPI Table and Methods for PCI Express* Support ................... 103
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}