$re = '/^[\d.]+(?:.|[\r\n])*?(?=[.\x20\t]+\d{2,3}$)/m';
$str = '5.2 Initializing the I/O Base Registers ................................. 51
5.3 Hiding and Function Disable troller Hub (PCH) Internal Devices 52
5.3.1 Fuse Disabled, Static Disabled, Non-Static Function Disable Device
Handling ................................................................. 53
8.4 SERR# Generation .................................................. 102
8.5 PCI Firmware Spec 3.0 Support ..................................... 103
8.6 ACPI Table and Methods for PCI Express* Support ................... 103
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);