import re
regex = re.compile(r"^[\d.]+(?:.|[\r\n])*?(?=[.\x20\t]+\d{2,3}$)", flags=re.MULTILINE)
test_str = ("5.2 Initializing the I/O Base Registers ................................. 51\n"
"5.3 Hiding and Function Disable troller Hub (PCH) Internal Devices 52\n"
"5.3.1 Fuse Disabled, Static Disabled, Non-Static Function Disable Device\n"
"Handling ................................................................. 53\n"
"8.4 SERR# Generation .................................................. 102\n"
"8.5 PCI Firmware Spec 3.0 Support ..................................... 103\n"
"8.6 ACPI Table and Methods for PCI Express* Support ................... 103\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")