const regex = /^.*?\(.*?\).*?\((.*?)\)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?\\(.*?\\).*?\\((.*?)\\)', '')
const str = `Lorem ipsum (dolor sit amet) 2015-02-03 22:04 - 2015-02-03 22:05 (tylko mirko) consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna (aliqua). `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}