// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^.*?\(.*?\).*?\((.*?)\)").unwrap();
let string = "Lorem ipsum (dolor sit amet) 2015-02-03 22:04 - 2015-02-03 22:05 (tylko mirko) consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna (aliqua). ";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}