#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s+[A-Ga-g](b|#|m|mi|min|M|maj|bm|#m|#mi|bmi|bmin|#min|sus|dim|[1-9]+)\s+"
Local $sString = "808—Bass Loop Dm 147bpm.wav" & @CRLF & _
"Drifting 100bpm F7 18.aif" & @CRLF & _
"120bpm Awakened Fdim.mp3" & @CRLF & _
"Rhodes 90bpm Am7sus4.ogg" & @CRLF & _
"01 Awakened 120bpm C#M9Gm9.caf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")