const regex = /^[pP]{2}[^a-m](?!.*(.).*\1)\d{5}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[pP]{2}[^a-m](?!.*(.).*\\1)\\d{5}$', 'gm')
const str = `ppt92613
ppy92619
ppt92617
PPr99999k`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}