$re = '/^[pP]{2}[^a-m](?!.*(.).*\1)\d{5}$/m';
$str = 'ppt92613
ppy92619
ppt92617
PPr99999k';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);