re = /^[pP]{2}[^a-m](?!.*(.).*\1)\d{5}$/m
str = 'ppt92613
ppy92619
ppt92617
PPr99999k'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end