import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div(.*?)<\\/div>";
final String string = "<div class=\"portlet-body author-note\"><p>Thanks to the massive new influx of patrons! You guys rock! (and stone!)</p>\n"
+ "<div class=\"spoiler\">\n"
+ "<div class=\"smalltext\"><strong>Spoiler</strong> : <input class=\"spoilerButton\"/></div>\n\n"
+ "</div>\n"
+ "<div class=\"spoiler\">\n\n\n"
+ "</div>\n"
+ " <p>R Quam<br/>\n"
+ " Rory<br/>\n"
+ " PiMs<br/>\n"
+ " Imi256<br/>\n"
+ " Thomas Belvin<br/>\n"
+ " Jacob<br/>\n\n"
+ "<p> </p>\n"
+ "<p>We are currently reaching 3 weeks </p>\n"
+ "</div>\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}