# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<div(.*?)<\/div>"
test_str = ("<div class=\"portlet-body author-note\"><p>Thanks to the massive new influx of patrons! You guys rock! (and stone!)</p>\n"
"<div class=\"spoiler\">\n"
"<div class=\"smalltext\"><strong>Spoiler</strong> : <input class=\"spoilerButton\"/></div>\n\n"
"</div>\n"
"<div class=\"spoiler\">\n\n\n"
"</div>\n"
" <p>R Quam<br/>\n"
" Rory<br/>\n"
" PiMs<br/>\n"
" Imi256<br/>\n"
" Thomas Belvin<br/>\n"
" Jacob<br/>\n\n"
"<p> </p>\n"
"<p>We are currently reaching 3 weeks </p>\n"
"</div>\n"
" </div>")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.