// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)<div(.*?)<\/div>").unwrap();
let string = "<div class=\"portlet-body author-note\"><p>Thanks to the massive new influx of patrons! You guys rock! (and stone!)</p>
<div class=\"spoiler\">
<div class=\"smalltext\"><strong>Spoiler</strong> : <input class=\"spoilerButton\"/></div>
</div>
<div class=\"spoiler\">
</div>
<p>R Quam<br/>
Rory<br/>
PiMs<br/>
Imi256<br/>
Thomas Belvin<br/>
Jacob<br/>
<p> </p>
<p>We are currently reaching 3 weeks </p>
</div>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}