re = /<div(.*?)<\/div>/m
str = '<div class="portlet-body author-note"><p>Thanks to the massive new influx of patrons! You guys rock! (and stone!)</p>
<div class="spoiler">
<div class="smalltext"><strong>Spoiler</strong> : <input class="spoilerButton"/></div>
</div>
<div class="spoiler">
</div>
<p>R Quam<br/>
Rory<br/>
PiMs<br/>
Imi256<br/>
Thomas Belvin<br/>
Jacob<br/>
<p> </p>
<p>We are currently reaching 3 weeks </p>
</div>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end