using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(([a-zA-Z0-9]{1,}\.png)|([a-zA-Z0-9]{1,}\.jpg)|([a-zA-Z0-9]{1,}\.gif))\b$";
string input = @"file.png
file2.jpg
file3.gif
1file.doc
.png
1.png
f.pngs";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}