package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(([a-zA-Z0-9]{1,}\.png)|([a-zA-Z0-9]{1,}\.jpg)|([a-zA-Z0-9]{1,}\.gif))\b$`)
var str = `file.png
file2.jpg
file3.gif
1file.doc
.png
1.png
f.pngs`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}