import re
regex = re.compile(r"\b(([a-zA-Z0-9]{1,}\.png)|([a-zA-Z0-9]{1,}\.jpg)|([a-zA-Z0-9]{1,}\.gif))\b$", flags=re.MULTILINE)
test_str = ("file.png\n"
"file2.jpg\n"
"file3.gif\n"
"1file.doc\n"
".png\n"
"1.png\n"
"f.pngs")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")