re = /\b(([a-zA-Z0-9]{1,}\.png)|([a-zA-Z0-9]{1,}\.jpg)|([a-zA-Z0-9]{1,}\.gif))\b$/m
str = 'file.png
file2.jpg
file3.gif
1file.doc
.png
1.png
f.pngs'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end