import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([1-9])(\\1)0$";
final String string = "/* MATCH */\n"
+ "110\n"
+ "220\n"
+ "330\n"
+ "440\n"
+ "550\n"
+ "660\n"
+ "770\n"
+ "880\n"
+ "990\n"
+ "/* NO MATCH */\n"
+ "000\n"
+ "111\n"
+ "2201\n"
+ "9900\n"
+ "10100\n"
+ "100\n"
+ "010\n"
+ "120\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}