$re = '/^([1-9])(\1)0$/m';
$str = '/* MATCH */
110
220
330
440
550
660
770
880
990
/* NO MATCH */
000
111
2201
9900
10100
100
010
120
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);