#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\d[ -]*?){13,16}\b"
Local $sString = "9999 - 9999 - 9999 - 9" & @CRLF & _
"9999 - 9999 - 9999 - 99" & @CRLF & _
"9999 - 9999 - 9999 - 999" & @CRLF & _
"9999 - 9999 - 9999 - 9999" & @CRLF & _
"999 - 999 - 999 - 999 - 999" & @CRLF & _
"99-99-99-99-99-99-99" & @CRLF & _
"9-9-9-9-9-9-9-9-9-9-9-9-9" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")