import re
regex = re.compile(r"(?:\d[ -]*?){13,16}\b")
test_str = ("9999 - 9999 - 9999 - 9\n"
"9999 - 9999 - 9999 - 99\n"
"9999 - 9999 - 9999 - 999\n"
"9999 - 9999 - 9999 - 9999\n"
"999 - 999 - 999 - 999 - 999\n"
"99-99-99-99-99-99-99\n"
"9-9-9-9-9-9-9-9-9-9-9-9-9\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")