import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\d[ -]*?){13,16}\\b";
final String string = "9999 - 9999 - 9999 - 9\n"
+ "9999 - 9999 - 9999 - 99\n"
+ "9999 - 9999 - 9999 - 999\n"
+ "9999 - 9999 - 9999 - 9999\n"
+ "999 - 999 - 999 - 999 - 999\n"
+ "99-99-99-99-99-99-99\n"
+ "9-9-9-9-9-9-9-9-9-9-9-9-9\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}