#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?i)(?:http:\/\/)?(?:w+\.)?\K\w+(?=\.[a-z]{2,4})"
Local $sString = "www.facebook.com http://www.facebook.com http://facebook.com "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)