$re = '/(?i)(?:http:\/\/)?(?:w+\.)?\K\w+(?=\.[a-z]{2,4})/m';
$str = 'www.facebook.com http://www.facebook.com http://facebook.com ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;