using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?:http:\/\/)?(?:w+\.)?\K\w+(?=\.[a-z]{2,4})";
string substitution = @"";
string input = @"www.facebook.com http://www.facebook.com http://facebook.com ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}